Back to overview
Resolved

Login unavailable — third-party authentication provider outage

Jul 16, 2026 at 9:43am UTC
Affected services
app.magellancx.com

Resolved
Jul 16, 2026 at 10:14am UTC

This incident has been resolved. WorkOS, our third-party authentication provider, has identified the cause, deployed a fix, and error rates have returned to normal.

We have confirmed that logging in to app.magellancx.com is working again. All services are fully operational.

Thank you for your patience. If you continue to experience any issues logging in, please contact our support team.

Created
Jul 16, 2026 at 9:43am UTC

We are currently investigating an issue that is preventing users from logging in to app.magellancx.com.

This is caused by a major outage at WorkOS, the third-party identity provider we use for authentication. As a result, new logins are currently failing.

Our team is actively monitoring the situation and is in contact with the provider. We will provide further updates as more information becomes available.

You can follow the provider's status here: https://status.workos.com/